چگونه php.ini را در سرورهای هاستینگ اشتراکی ویرایش کنیم؟

با کمک انتخابگر PHP که ما در سرورهای اشتراکی خود قرار داده ایم، شما به راحتی می توانید تنظیمات پایه PHP را در کنترل پنل cPanel، بخش Software/Services و منوی Select PHP Version تغییر دهید.

جزئیات بیشتر را در اینجا بیابید.

با این حال، تنظیمات پیشرفته PHP را نمی توان از طریق PHP Selector تغییر داد، و نیاز است که به صورت دستی فایل php.ini را تنظیم کنید.

 

شما می توانید فایل php.ini را بر اساس نسخه های مختلف PHP از این قسمت دانلود کنید:

وقتی که همه به روز رسانی ها تکمیل شد، مطمئن شوید که فایل را به php.ini تغییر دهید و تنظیمات suPHP را هم اضافه کنید.

 

برای اینکه بفهمید نسخه فعلی و تنظیمات فعلی PHP شما چیست، به این مقاله مراجعه کنید.

چگونه نسخه PHP را در سرورهای هاستینگ اشتراکی تغییر دهیم؟

در بعضی موارد، عملکرد صحیح وب سایت شما بستگی به نسخه PHP نصب شده بر روی سرور دارد.

با استفاده از قابلیت PHP Selector، این موضوع ممکن شده است که بتوان نسخه مورد نیاز PHP را انتخاب نمود و حتی ماژولها و عملگرهای مشخصی از PHP را فعال یا غیرفعال نمود.

برای اینکه بفهمید از چه نسخه ی PHP استفاده می کنید، به این مقاله مراجعه کنید.

برای تغییر نسخه PHP، مراحل زیر را دنبال کنید:

  1. وارد حساب cPanel خود بشوید.
  2. به قسمت Software/Services مراجعه کنید و گزینه Select PHP Version را انتخاب کنید:php_selector_01
  3. در این صفحه لیست ماژول ها و عملگرهای موجود را مشاهده می کنید.در صورتی که نیاز به تغییر نسخه PHP ندارید و تنها می خواهید که بعضی ماژول ها را فعال یا غیرفعال کنید، شما می توانید با تیک زدن یا برداشتن تیک هریک از گزینه ها وضعیت آنها را تغییر دهید.از لیست PHP Version می توانید برای انتخاب یک نسخه به خصوص از PHP استفاده کنید، بر روی Set as current کلیک کنید تا تغییرات اعمال شود.

    توجه: نسخه “native” مربوط به PHP اجازه انجام تغییر در مشخصه ها را به شما نمی دهد. شما می توانید تغییرات مورد نظر خود را با استفاده از یک فایل php.ini ایجاد کنید:

    php_selector_02

  4. برای تغییر در تنظیمات مربوط به نسخه PHP انتخابی، بر روی گزینه Switch to PHP Settings کلیک کنید.با کلیک کردن بر روی یکی از گزینه های به رنگ خاکستری، یک لیست به شما نشان داده می شود که از داخل آن می توان تنظیمات بخصوصی را انتخاب کنید. بر روی گزینه Apply کلیک کنید تا تغییرات اعمال شود:php_selector_03

    نکته 1: توصیه می شود که اسکریپت های وب سایت خود را به روز رسانی کنید و حداقل از نسخه 5.4 مربوط PHP استفاده کنید. اگر آخرین نسخه اسکریپتی که استفاده می کنید با این نسخه از PHP سازگار نیست، حتما نسخه ای را تهیه کنید که سازگار باشد.

    نکته 2: اگر قبلا از یک فایل php.ini برای ویرایش تنظیمات PHP حساب خود استفاده نموده اید، نیاز است که مقادیر مرتبط با آن را از طریق PHP Selector tool تنظیم کنید.

    نکته 3: برای افزایش حداکثر حجم آپلود، مطمئن شوید که هر دو مقدار post_max_size و upload_max_filesize را تنظیم نمایید.

 

نیاز به راهنمایی بیشتر دارید؟ به قسمت پشتیبانی ما مراجعه کنید.